Civil 3d - Fail

Notou algum erro no seu civil 3d?
civil 3d 2009:
Não está colocando a bandeirinha de "Out of date" nos corridors quando alteramos o greide usado por algum deles... PARECE que o sp1 resolve isso, mas não estou vendo isso aqui não
Tambem os métodos de coletar as coordenadas de inicio e fim de um Pipe (pipenetwork) não estão retornando algo utilizavel, por exemplo:
(Setq pipe (vlax-ename->vla-object (car (entsel "\nClique um tubo"))))
(
setq startpoint (vlax-get-property pipe "startpoint"))

(
setq pt (list  (vlax-get-property startpoint "x")
        (
vlax-get-property startpoint "y")
        (
vlax-get-property startpoint "z")))


Retorna um erro:
; error: ActiveX Server returned an error: Elemento não encontrado
No 2008 retorna a coordenada esperada...
não testei no 2007 ou anteriores...

Entendo que haja evoluções, por exemplo, no 2009 é possível saber o VLA do pipe, se clicarmos o pipe num perfil, mas no 2008 não... Ou o método ADD para adicionar um perfil ao alinhamento, sofreu uma alteração onde não e necessário informar estacas inicial e final
no 2009:
HRESULT Add(
[in] BSTR Name,
[in] AeccProfileType ProfileType,
[in] VARIANT ProfileStyle,
[out,retval] IAeccProfile** profile
);

no 2008:
HRESULT Add(
[in] BSTR Name,
[in] AeccProfileType ProfileType,
[in] VARIANT ProfileStyle,
[in] double SampleStartStation,
[in] double SampleEndStation,
[in] BSTR LayerName,
[out,retval] IAeccProfile** profile
);

Não que seja um problema, desde que funcione...

2007:
Tinha o problema com os points... sempre que o mouse parava sobre um ponto, era como se todos estivessem agrupados... sinceramente eu não usava os pontos do c3d2007, usava os do Posicao

2007 e 2008 grading: fatal error se você "strechasse" a feateure line do grading e fizesse UNDO algumas vezes

E você? achou alguma coisa?

LinkWithin

Related Posts Plugin for WordPress, Blogger...